the Studio Organizer is No Longer Mac Compatible

When Apple released OS X 10.13 they removed code necessary for the Studio Organizer to run on their new operating systems.

Unfortunately there is no workaround available and the Studio Organizer will only run on OS X 10.9 through 10.12.

With this in mind, if you would like to download the Macintosh version please click this link.

Join Our Mailing List

• Special Offers & Discounts
• No Spam
• Unsubscribe Anytime